Build 1.6.2

View previous topic View next topic Go down

Build 1.6.2

Post by Admin on Tue Jun 11, 2013 11:38 am

Build 1.6.2 contains more fixes for the watch routine.
Also includes the start of being able to tell if the device is plugged in or not.

Couple things I want to go over. After the update I probably won’t even look at it until tomorrow as google has once again blocked my ip address.

With the watch routine I am getting to the point of struggling. The app was built to be a simple time based updater. I didn’t want to copy Btraced as there is no point. It already exists. The app currently on my system functions well. If I turn the distance to on it will track me on my set distance. If I run interval, which primarily what I do then it tracks based on the time schedule.

Some things I have noticed:
1. If you’re in distance mode and sitting still it will eventually kill the radio after 15 mins or so. I am trying to find a way around this. As I said it wasn’t built for it so I have to add it little by little and test.

2. Sometimes you will miss points of data. This actually has multiple issues. GPS radio and cell radio are totally different. Even though you have a great gps signal there is no guarantee that you will push an update. If your cell signal is low or crappy, the update can fail. Basically what the app is doing is calling a web page in HS. If that webpage responds then the update goes through. There is a timeout set on this update of 20 secs. So if the app does not get a response from HS within 20 secs it bails. This creates its own little problem. If you are trying to run distance mode and have a low setting and are traveling 70mph down the highway and it fails after 20 seconds then it tries to send another update right on top of that because of the distance setting you can overload HS. A solution would be for me to turn the update down to 5 seconds. Problem with that is you will now run into issues of when the cell signal is low you will lose more updates.

3. A solution for the above would be to do multiple uploads at once. In other words when in distance mode save all the data until you’re done. Then stop the “trip” and it will upload. At this point I have just created Btraced and made a trip tracker.

So basically I am trying to figure out which route to go. Re-create how Btraced works or simply say don’t run the thing below 100 meters when in distance mode. At this point if you ran in interval mode at its lowest setting you would get approx. 1 update per mile at highway speeds. A little less if you’re flying down the road. At slower speeds in town you would be getting 2 or more updates per mile.

Not saying I am giving up. Just need some user input.
Again this will be on the forums for any replies.

Greg
Build 1.6.2 contains more fixes for the watch routine.
Also includes the start of being able to tell if the device is plugged in or not.

Couple things I want to go over. After the update I probably won’t even look at it until tomorrow as google has once again blocked my ip address.

With the watch routine I am getting to the point of struggling. The app was built to be a simple time based updater. I didn’t want to copy Btraced as there is no point. It already exists. The app currently on my system functions well. If I turn the distance to on it will track me on my set distance. If I run interval, which primarily what I do then it tracks based on the time schedule.

Some things I have noticed:
1. If you’re in distance mode and sitting still it will eventually kill the radio after 15 mins or so. I am trying to find a way around this. As I said it wasn’t built for it so I have to add it little by little and test.

2. Sometimes you will miss points of data. This actually has multiple issues. GPS radio and cell radio are totally different. Even though you have a great gps signal there is no guarantee that you will push an update. If your cell signal is low or crappy, the update can fail. Basically what the app is doing is calling a web page in HS. If that webpage responds then the update goes through. There is a timeout set on this update of 20 secs. So if the app does not get a response from HS within 20 secs it bails. This creates its own little problem. If you are trying to run distance mode and have a low setting and are traveling 70mph down the highway and it fails after 20 seconds then it tries to send another update right on top of that because of the distance setting you can overload HS. A solution would be for me to turn the update down to 5 seconds. Problem with that is you will now run into issues of when the cell signal is low you will lose more updates.

3. A solution for the above would be to do multiple uploads at once. In other words when in distance mode save all the data until you’re done. Then stop the “trip” and it will upload. At this point I have just created Btraced and made a trip tracker.

So basically I am trying to figure out which route to go. Re-create how Btraced works or simply say don’t run the thing below 100 meters when in distance mode. At this point if you ran in interval mode at its lowest setting you would get approx. 1 update per mile at highway speeds. A little less if you’re flying down the road. At slower speeds in town you would be getting 2 or more updates per mile.

Not saying I am giving up. Just need some user input.
Again this will be on the forums for any replies.

Greg
avatar
Admin
Admin

Posts : 68
Join date : 2013-06-05

View user profile http://dageek.forumotion.com

Back to top Go down

Re: Build 1.6.2

Post by Jayman13 on Tue Jun 11, 2013 11:52 am

I get what you're saying and I really appreciate all the hard work you have put into this. As far as re-creating btraced, in my opinion, i think that is a non-issue. In btraced you can set it to timed updates instead of distance so in effect it is too late. That said, your app connects directly to snevl and is more homeseer inclined being developed by a homeseer user. I may be in the minority here but I would prefer set it and forget it. It tracks you precisely when you're moving and doesn't need to when yoj are staying put. Events can then be run precisely and what it could do is just about anything with homeseer. Just my 2 cents.

Jayman13

Posts : 51
Join date : 2013-06-05

View user profile

Back to top Go down

Re: Build 1.6.2

Post by Admin on Tue Jun 11, 2013 12:02 pm

Jayman13 wrote:I get what you're saying and I really appreciate all the hard work you have put into this. As far as re-creating btraced, in my opinion, i think that is a non-issue. In btraced you can set it to timed updates instead of distance so in effect it is too late. That said, your app connects directly to snevl and is more homeseer inclined being developed by a homeseer user. I may be in the minority here but I would prefer set it and forget it. It tracks you precisely when you're moving and doesn't need to when yoj are staying put. Events can then be run precisely and what it could do is just about anything with homeseer. Just my 2 cents.

So Jay are you saying, that if you can just turn on distance and do your thing that's what you need to make it work for you? Cuz if we get your issue worked out that is technically what it will do. Although I suggest you keep your distance setting to about 300 to 350 meters. At this point the only user interaction is when you reboot you phone. You would need launch the app. Just can't seem to get around that.
avatar
Admin
Admin

Posts : 68
Join date : 2013-06-05

View user profile http://dageek.forumotion.com

Back to top Go down

Re: Build 1.6.2

Post by Jayman13 on Tue Jun 11, 2013 12:29 pm

Yeah, but it would be cool too to save battery if it changed from being constantly on to timed updates when you were stationary and then distance updated when moving. One way to do that for me would be when it is charging as you are already working on. Btw, with the most recent update it died again in about the same time span. I am stationary at this time...

Jayman13

Posts : 51
Join date : 2013-06-05

View user profile

Back to top Go down

Re: Build 1.6.2

Post by Admin on Tue Jun 11, 2013 5:35 pm

Having amajor Ah HA moment here.

I may have a solution to the timeout after non movement. If all goes according to plan I may have a test version up tomorrow. If it works I can then begin adding the plugged in variable.
avatar
Admin
Admin

Posts : 68
Join date : 2013-06-05

View user profile http://dageek.forumotion.com

Back to top Go down

Re: Build 1.6.2

Post by Jayman13 on Tue Jun 11, 2013 6:07 pm

Nice!

Jayman13

Posts : 51
Join date : 2013-06-05

View user profile

Back to top Go down

Re: Build 1.6.2

Post by jbbtex on Tue Jun 11, 2013 9:02 pm

The app has been working great for me. But I'm fine with the timed updates. Like Jay, I really appreciate the work you've done. And, again seconding him, it's wonderful having an app designed to work with Steve's Latitude scripts. I'm ready for a production version, so I get the rest of the family off Google.

Brady

jbbtex

Posts : 11
Join date : 2013-06-05

View user profile

Back to top Go down

Re: Build 1.6.2

Post by Gogs on Wed Jun 12, 2013 10:59 am

Ok this is worrying for me.

Since upgrade Snevl is not processing any info! fired up Btraced and it works perfectly!

My problems started after I installed your last HTML file.

I have double check all the settings.
avatar
Gogs

Posts : 27
Join date : 2013-06-05

View user profile

Back to top Go down

Re: Build 1.6.2

Post by Admin on Wed Jun 12, 2013 11:03 am

Gogs wrote:Ok this is worrying for me.

Since upgrade Snevl is not processing any info! fired up Btraced and it works perfectly!

My problems started after I installed your last HTML file.

I have double check all the settings.

The file should have been Snevl_GpsToHS.aspx. And you should have placed it in the html directory of HS. Directly in the html folder in HS. Make sure you didn't place it any lower or higher in the directory structure. I will email the zip file to you again.
avatar
Admin
Admin

Posts : 68
Join date : 2013-06-05

View user profile http://dageek.forumotion.com

Back to top Go down

Re: Build 1.6.2

Post by Gogs on Wed Jun 12, 2013 11:23 am

Admin wrote:
Gogs wrote:Ok this is worrying for me.

Since upgrade Snevl is not processing any info! fired up Btraced and it works perfectly!

My problems started after I installed your last HTML file.

I have double check all the settings.



The file should have been Snevl_GpsToHS.aspx. And you should have placed it in the html directory of HS. Directly in the html folder in HS. Make sure you didn't place it any lower or higher in the directory structure. I will email the zip file to you again.

Recieved the file, thanks, still not updating, so, going to delete the user name and start as a new user.
avatar
Gogs

Posts : 27
Join date : 2013-06-05

View user profile

Back to top Go down

Re: Build 1.6.2

Post by Gogs on Wed Jun 12, 2013 12:41 pm

Re-installed and all are back on speaking terms, but, no map!

One thing I have noticed are the speeds are ridiculous and Snevl is set to ignore reticules speeds or distance.

I tried to post an image of the track, but, don't have permissions.
avatar
Gogs

Posts : 27
Join date : 2013-06-05

View user profile

Back to top Go down

Re: Build 1.6.2

Post by Admin on Wed Jun 12, 2013 12:48 pm

Gogs wrote:Re-installed and all are back on speaking terms, but, no map!

One thing I have noticed are the speeds are ridiculous and Snevl is set to ignore reticules speeds or distance.

I tried to post an image of the track, but, don't have permissions.

I am not reporting speeds at all.
If you are referring to the "Location Accruracy Radius". Then that can be a little out of sync. It usually (depending on signal) is around 50 to 110. You can get crazy readings like 3000 or above. But those usually calm down after a few updates.

Email me the screenshot. To be honest this is the first time I used this forum and have no idea how to post screenshots. LOL!
avatar
Admin
Admin

Posts : 68
Join date : 2013-06-05

View user profile http://dageek.forumotion.com

Back to top Go down

Re: Build 1.6.2

Post by Gogs on Wed Jun 12, 2013 12:53 pm

Admin wrote:
Gogs wrote:Re-installed and all are back on speaking terms, but, no map!

One thing I have noticed are the speeds are ridiculous and Snevl is set to ignore reticules speeds or distance.

I tried to post an image of the track, but, don't have permissions.



I am not reporting speeds at all.
If you are referring to the "Location Accruracy Radius". Then that can be a little out of sync. It usually (depending on signal) is around 50 to 110. You can get crazy readings like 3000 or above. But those usually calm down after a few updates.

Email me the screenshot. To be honest this is the first time I used this forum and have no idea how to post screenshots. LOL!

Have emailed you and everyone else in the loop a screenshot.
avatar
Gogs

Posts : 27
Join date : 2013-06-05

View user profile

Back to top Go down

Re: Build 1.6.2

Post by Admin on Wed Jun 12, 2013 1:07 pm

I think I may know the issue.
For testing and because I haven't got to it yet there is something on my list to correct.

For the whole distance thing, on the app startup I am setting a location lat and lon of south Africa. This is just to make an initial calculation.

I plan on removing it and grabbing a current location then calculating. This only happens when the app is completely off and is re-started. That may be what is happening. I didn't even know steve was showing that. Still not sure how it would effect your maps though.

I will work on getting this out of there.
avatar
Admin
Admin

Posts : 68
Join date : 2013-06-05

View user profile http://dageek.forumotion.com

Back to top Go down

Re: Build 1.6.2

Post by Gogs on Wed Jun 12, 2013 1:17 pm

Admin wrote:I think I may know the issue.
For testing and because I haven't got to it yet there is something on my list to correct.

For the whole distance thing, on the app startup I am setting a location lat and lon of south Africa. This is just to make an initial calculation.

I plan on removing it and grabbing a current location then calculating. This only happens when the app is completely off and is re-started. That may be what is happening. I didn't even know steve was showing that. Still not sure how it would effect your maps though.

I will work on getting this out of there.

It would effect the Maps in so far as If I have lost them for whatever reason Snevl will not regenarete them if it's getting crazy distance and time such as travelled 0.5 miles at 500 mph!
avatar
Gogs

Posts : 27
Join date : 2013-06-05

View user profile

Back to top Go down

Re: Build 1.6.2

Post by Admin on Wed Jun 12, 2013 1:21 pm

Gogs wrote:
Admin wrote:I think I may know the issue.
For testing and because I haven't got to it yet there is something on my list to correct.

For the whole distance thing, on the app startup I am setting a location lat and lon of south Africa. This is just to make an initial calculation.

I plan on removing it and grabbing a current location then calculating. This only happens when the app is completely off and is re-started. That may be what is happening. I didn't even know steve was showing that. Still not sure how it would effect your maps though.

I will work on getting this out of there.



It would effect the Maps in so far as If I have lost them for whatever reason Snevl will not regenarete them if it's getting crazy distance and time such as travelled 0.5 miles at 500 mph!

That's been in there since early last week. Odd it shows up now. Did you try going for a little one mile ride and see if that fixes it? I know Snevl won't update until you move.

I'll try on get it out of there as quick as I can. But I wonder if it's stuck in there because it exists in the table. I am not sure if you delete a user if steve deletes their data also.
avatar
Admin
Admin

Posts : 68
Join date : 2013-06-05

View user profile http://dageek.forumotion.com

Back to top Go down

Re: Build 1.6.2

Post by Gogs on Wed Jun 12, 2013 1:28 pm

Admin wrote:
Gogs wrote:
Admin wrote:I think I may know the issue.
For testing and because I haven't got to it yet there is something on my list to correct.

For the whole distance thing, on the app startup I am setting a location lat and lon of south Africa. This is just to make an initial calculation.

I plan on removing it and grabbing a current location then calculating. This only happens when the app is completely off and is re-started. That may be what is happening. I didn't even know steve was showing that. Still not sure how it would effect your maps though.

I will work on getting this out of there.





It would effect the Maps in so far as If I have lost them for whatever reason Snevl will not regenerate them if it's getting crazy distance and time such as travelled 0.5 miles at 500 mph!



That's been in there since early last week. Odd it shows up now. Did you try going for a little one mile ride and see if that fixes it? I know Snevl won't update until you move.

I'll try on get it out of there as quick as I can. But I wonder if it's stuck in there because it exists in the table. I am not sure if you delete a user if steve deletes their data also.

No I have not tried moving yet, that will be tomorrow.

Snevl does not delete a users data if you delete the user, just recreates the connection when the user is re-installed and picks up all the data from records.
avatar
Gogs

Posts : 27
Join date : 2013-06-05

View user profile

Back to top Go down

Re: Build 1.6.2

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum